Codoforum related discussions

Post all your questions and problems related to codoforum here .

317
5
kostas.petros posted Sep 18 '18 at 8:09 am

Are there any instructions of how to use it with Sqlite ?

I am using XAMPP and codoforum v4.4.
I tried to use the SQLITE db and get the following error:

Fatal error: Uncaught InvalidArgumentException: Database does not exist. in C:\xampp\htdocs\codoforum-sqlite\sys\vendor\illuminate\database\Illuminate\Database\Connectors\SQLiteConnector.php:32 Stack trace: 
#0 C:\xampp\htdocs\codoforum-sqlite\sys\vendor\illuminate\database\Illuminate\Database\Connectors\ConnectionFactory.php(59): Illuminate\Database\Connectors\SQLiteConnector->connect(Array) 
#1 C:\xampp\htdocs\codoforum-sqlite\sys\vendor\illuminate\database\Illuminate\Database\Connectors\ConnectionFactory.php(47): Illuminate\Database\Connectors\ConnectionFactory->createSingleConnection(Array) 
#2 C:\xampp\htdocs\codoforum-sqlite\sys\vendor\illuminate\database\Illuminate\Database\DatabaseManager.php(127): Illuminate\Database\Connectors\ConnectionFactory->make(Array, 'default') 
#3 C:\xampp\htdocs\codoforum-sqlite\sys\vendor\illuminate\database\Illuminate\Database\DatabaseManager.php(63): Illuminate\Database\Data in C:\xampp\htdocs\codoforum-sqlite\sys\vendor\illuminate\database\Illuminate\Database\Connectors\SQLiteConnector.php on line 32
recent by mattsmith  ·  Oct 5 '18 at 12:16 am
77
0
kostas.petros posted Sep 21 '18 at 7:05 pm

v4.4 and IE8 does not work :

Error: Expected Identifier in the following code:

        <!--[if lte IE 8]>
         <script src="//cdnjs.cloudflare.com/ajax/libs/json2/20121008/json2.min.js"></script>
        <![endif]-->

Any workaround or any ideas please ?

1.1k
0

My config

$config['sess_driver']= 'database';
$config['sess_cookie_name']= 'cisession';
$config['sess_expiration']= 7200;
$config['sess_save_path']= 'ci_session';
$config['sess_match_ip']= TRUE;
$config['sess_time_to_update']= 0;
$config['sess_regenerate_destroy']= FALSE;
$config['sess_use_database']= TRUE;
$config['sess_expire_on_close']= FALSE;
$config['sess_table_name']= 'ci_session';
$config['sess_match_useragent']=FALSE;

dashbord code

<?php

if (isset($_SESSION['uid']))
{
$uid = $this->session->userdata('uid');
//print_r($userdata);
}
else {
header("Location: admin");
}

?>

controller

public function login()
    {
        $email=$this->input->post('useremail');
        $pass=$this->input->post('password');
         $check=$this->modal->check_login($email,$pass);
         if(count($check)>0){

            $uid=$check[0]->id;
            $this->session->set_userdata('uid',$uid);
            echo 1; // redirect to dashboard 
        }

Using plesk server

131
1
amithmahakala423 posted Aug 31 '18 at 8:30 am

I am using PEAR with php in apache webserver.
While launching the login page, we are getting the following error on the webpage.

can any one help me ??

Array
PRE:
DB_Error Object
(
[error_message_prefix] =>
[mode] => 1
[level] => 1024
[code] => -4
[message] => DB Error: not found
[userinfo] => Unable to include the DB/.php file for '
[backtrace] => Array
(
[0] => Array
(
[file] => /spfs/docs/support/PEAR/DB.php
[line] => 748
[function] => PEAR_Error
[class] => PEAR_Error
[object] => DB_Error Object
*RECURSION*
[type] => ->
[args] => Array
(
[0] => DB Error: not found
[1] => -4
[2] => 1
[3] => 1024
[4] => Unable to include the DB/.php file for
'
)

            )

        [1] => Array
            (
                [file] => /spfs/docs/support/PEAR/PEAR.php
                [line] => 536
                [function] => DB_Error
                [class] => DB_Error
                [object] => DB_Error Object

RECURSION
[type] => ->
[args] => Array
(
[0] => -4
[1] => 1
[2] => 1024
[3] => Unable to include the DB/.php file for `'
)

            )

        [2] => Array
            (
                [file] => /spfs/docs/support/PEAR/DB.php
                [line] => 380
                [function] => raiseError
                [class] => PEAR
                [type] => ::
                [args] => Array
                    (
                        [0] => 
                        [1] => -4
                        [2] => 
                        [3] => 
                        [4] => Unable to include the DB/.php file for `'
                        [5] => DB_Error
                        [6] => 1
                    )

            )

        [3] => Array
            (
                [file] => /spfs/docs/support/html/lib/core.php
                [line] => 54
                [function] => connect
                [class] => DB
                [type] => ::
                [args] => Array
                    (
                        [0] => 
                        [1] => Array
                            (
                                [debug] => 2
                                [portability] => 63
                            )

                    )

            )

        [4] => Array
            (
                [file] => /spfs/docs/support/html/lib/base.php
                [line] => 80
                [args] => Array
                    (
                        [0] => /spfs/docs/support/html/lib/core.php
                    )

                [function] => require_once
            )

        [5] => Array
            (
                [file] => /spfs/docs/support/html/welcome/index.php
                [line] => 3
                [args] => Array
                    (
                        [0] => /spfs/docs/support/html/lib/base.php
                    )

                [function] => require_once
            )

    )

[callback] => 

)
.:ERROR:.

 An error occurred while executing this script. Please try again later.

Error code: 256
Error message: DB Error: not found
Script name and line number of error: core.php:57

recent by admin  ·  Aug 31 '18 at 5:28 pm
256
8
Renoa posted Dec 21 '15 at 2:18 pm

hello!
i have set up my site with the idea that a category will allow unregistered users to post topics (about the problems they had registering, if any)
the problem is that i set up the 'guest' user permissions to allow posting and editing of topics for this particular category, and the 'post new topic' box appears to logged out users. if you try to click it, however, it takes you to the login page, and refuses to let the guest post a new topic.
any suggestions on how to make that happen? or is it not allowed in this system?

recent by admin  ·  May 26 '18 at 6:31 pm
134
1

If yes, how do I configure it to do so? I'm asking because there are templates I intend parsing on the site which have no part in the forum section. Do I need a separate installation to use smarty (as I can't find it in the location smarty installation guide suggested I'll see it) or can I tweak something in my target directory and then intercept the preexisting instance in the forum folder?

Many thanks.

recent by admin  ·  Apr 29 '18 at 5:26 pm
293
4
hard_as_snails posted Apr 3 '18 at 8:27 am

[4.3] - [UNDER DEVELOPMENT]

  • Profile avatar button [FIXED]
  • Search bar in mobile [DONE]
  • Edit profile with custom fields error [FIXED]
  • Handle request URI too long
  • Add descriptions for the new added permissions
  • Edit profile permissions incorrect
  • codopm add option send a copy via mail
  • codopm add more visible send pm button
  • Add sort by
  • FB sharing
  • Add option to precheck remember me
  • Search doesn't work well with pagination
  • Mark as read button not working
  • Enable Infinite scroll -> disable -> Active page shown wrong
  • Category labels feature
252
5
Aahz posted Dec 10 '17 at 12:06 pm

Hi,
I would like to change the variable <meta name="author" content="BABA"> and <meta name="generator" content=""> to something more suitable to may forum, and I'm not sure it is possible to do that via back-end control panel, so i assume it has to be harcode changed, yet i would like to keep that change future, updates friendly, as i heard there is a major update coming, and don't want to loose these changes.

Thanks a lot!

recent by admin  ·  Apr 15 '18 at 6:16 pm
210
1

This seems to be a unique forum. Every open source forum you find is very similar as far as how they look. They may have skins you can use which is basically throwing a costume on the same design but this is rather unique. How hard would it be to change up the style a little bit, may be add advertisements or other things to the sidebar, change color, header, basically play around with the style?

recent by admin  ·  Mar 22 '18 at 9:47 pm
116
0
Ankit Mechu posted Feb 23 '18 at 9:08 am

Hi everyone , I want to

  1. use https instead of https ,how can i change my default url
  2. how to change htacces so that system can automatically redirect non-https to https
909
4.41k
22
Sub Categories
Actions
Hide topic messages
Enable infinite scrolling
Previous
1 ... 6789101112 ... 46
Next
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft