FreiChat related discussions
Chat is gone after a CronJobs issue

Hi, I installed FreiChat on a HumHub site. It worked fine until a CroneJobs issue. After that the chat bubble doesn't appeared any more (I assume the problem started after that). I have unistalled and re installed many times the chat module, and even have deleted the site account on the dashboard of FreiChat, and the chat continues without appears.


I also have a previous test site, and the chat works perfectly there. Any help, will be appreciated.


Hi, I installed FreiChat on a HumHub site. It worked fine until a CroneJobs issue. After that the chat bubble doesn't appeared any more (I assume the problem started after that). I have unistalled and re installed many times the chat module, and even have deleted the site account on the dashboard of FreiChat, and the chat continues without appears. I also have a previous test site, and the chat works perfectly there. Any help, will be appreciated.

Please be so kind and check whether you get an error message in the browser developer console and if so, please copy & paste it here.


Maybe you did the setup in a wrong way - you can make use of a online Cron Generator like:


With the following tool you can test your crone setup:


I hope this will help you.


Kind regards,


Andy smile


Please be so kind and check whether you get an error message in the browser developer console and if so, please copy & paste it here. Maybe you did the setup in a wrong way - you can make use of a online Cron Generator like: - https://crontab-generator.org - or - http://www.cronmaker.com/;jsessionid=node0ibb0m6wi1f921u3geobgbbzlp1693022.node0?0 With the following tool you can test your crone setup: - https://crontab.guru I hope this will help you. Kind regards, Andy :)

Thanks a lot for your reply, Andy. Here I attach a screenshot of the console error on the browser.!


6130d5f7ca761


Indeed, I haven't had scheduled any CronJobs on the server when the chat disappeared. My skills on web development aren't so much.


On Humhub it appeared me an error about the cronjobs not completed, so I entered the section on Cpanel to fill the job following 2 lines command showed on the help of HH itself, which I copy here


/usr/local/bin/php /home/ROOT/public_html/humhub/protected/yii cron/run >/dev/null 2>&1
/usr/local/bin/php /home/ROOT/public_html/humhub/protected/yii queue/run >/dev/null 2>&1

But I think they are command lines just fot HH and I assume for the error on the browser that FreiChat needs some extra cronjobs and command lines, perhaps?


Any help, will be so grateful. Thanks!


Thanks a lot for your reply, Andy. Here I attach a screenshot of the console error on the browser.! ![6130d5f7ca761](serve/attachment&path=6130d5f7ca761) Indeed, I haven't had scheduled any CronJobs on the server when the chat disappeared. My skills on web development aren't so much. On Humhub it appeared me an error about the cronjobs not completed, so I entered the section on Cpanel to fill the job following 2 lines command showed on the help of HH itself, which I copy here ```` /usr/local/bin/php /home/ROOT/public_html/humhub/protected/yii cron/run >/dev/null 2>&1 ```` ```` /usr/local/bin/php /home/ROOT/public_html/humhub/protected/yii queue/run >/dev/null 2>&1 ```` But I think they are command lines just fot HH and I assume for the error on the browser that FreiChat needs some extra cronjobs and command lines, perhaps? Any help, will be so grateful. Thanks!

I can tell you I had also some very bad problems with the correct setup of the Cron Jobs with HumHub too. If You check the HumHub community you can see that I did once most of the free modules and some themes for HH. My problems with the setup of Crons was only one reason for me to stop using HH.


The thing with the Cron Jobs in general is - you can find masses of tutorials and explanations but at the end every hosting provider does handle them a bit different, depending on how they setup their system. So it can't hurt to check the tutorials at your hosting provider or to ask their support. The screenshot also shows me that an https URL is required for the desktop notifications (if you want to use them) (google "free https" otherwise you have to pay your hosting provider some money for it).


At your screenshot I can see that there are some issues with outdated 3dparty dependencies (APIs). I think it is the best our main developer and admin of Codologic @admin will check out whats going on here.

Please be patient a little longer, we will find a solution. smile


Kind regards,


Andy smile


I can tell you I had also some very bad problems with the correct setup of the Cron Jobs with HumHub too. If You check the HumHub community you can see that I did once most of the free modules and some themes for HH. My problems with the setup of Crons was only one reason for me to stop using HH. The thing with the Cron Jobs in general is - you can find masses of tutorials and explanations but at the end every hosting provider does handle them a bit different, depending on how they setup their system. So it can't hurt to check the tutorials at your hosting provider or to ask their support. The screenshot also shows me that an **https URL** is required for the desktop notifications (if you want to use them) (google "free https" otherwise you have to pay your hosting provider some money for it). At your screenshot I can see that there are some issues with outdated 3dparty dependencies (APIs). I think it is the best our main developer and admin of Codologic @admin will check out whats going on here. Please be patient a little longer, we will find a solution. :) Kind regards, Andy ;)

Thanks a lot again, for your kind answer. Now I have already an a SSL certificate on my site, so I think this is not a problem any more.


Now, the console shows this errors. It seems some .js are deprecated? Any help from @admin will be very helpful.

61324580f1516


Thanks again!!


Thanks a lot again, for your kind answer. Now I have already an a SSL certificate on my site, so I think this is not a problem any more. Now, the console shows this errors. It seems some .js are deprecated? Any help from @admin will be very helpful. ![61324580f1516](serve/attachment&path=61324580f1516) Thanks again!!

Hi


Can you give us your website url with a test account so that we may have a look?
You can email us these details


Alternatively also can try this:


Clear the token you see in the FreiChat plugin save it and then reinstall it.


Hi Can you give us your website url with a test account so that we may have a look? You can email us these details Alternatively also can try this: Clear the token you see in the FreiChat plugin save it and then reinstall it.
Necessity is the mother of all inventions!

Thanks a lot! the 2nd choice worked perfectly


Do you thinks could be some other problem still without be solved? Any way, if you think necessary I can give you access to the site


Thanks again, @admin

Thanks a lot! the 2nd choice worked perfectly Do you thinks could be some other problem still without be solved? Any way, if you think necessary I can give you access to the site Thanks again, @admin

Hi @MaxRut

Please create a new topic if it is not solved with above given solution


Hi @MaxRut Please create a new topic if it is not solved with above given solution
Necessity is the mother of all inventions!
68
8
3
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft