General discussion
SSL(HTTPS) Mixed content errors

Is there any variable or something to change to made codoforum works on SSL site https or I have to change all the urls in files to not have that errors?

Mixed Content: The page at '<URL>' was loaded over HTTPS, but requested an insecure font '<URL>'. This request has been blocked; the content must be served over HTTPS.

Mixed Content: The page at 'https://forum.tibiaservers.net/' was loaded over HTTPS, but requested an insecure font 'http://forum.tibiaservers.net/sites/default/themes/default/fonts/fontawesome-webfont.woff2?v=4.7.0'. This request has been blocked; the content must be served over HTTPS.
(index):1 Mixed Content: The page at 'https://forum.tibiaservers.net/' was loaded over HTTPS, but requested an insecure font 'http://forum.tibiaservers.net/sites/default/themes/default/fonts/fontawesome-webfont.woff?v=4.7.0'. This request has been blocked; the content must be served over HTTPS.

**Is there any variable or something to change to made codoforum works on SSL site https or I have to change all the urls in files to not have that errors?** _Mixed Content: The page at &#039;&lt;URL&gt;&#039; was loaded over HTTPS, but requested an insecure font &#039;&lt;URL&gt;&#039;. This request has been blocked; the content must be served over HTTPS._ _Mixed Content: The page at &#039;https://forum.tibiaservers.net/&#039; was loaded over HTTPS, but requested an insecure font &#039;http://forum.tibiaservers.net/sites/default/themes/default/fonts/fontawesome-webfont.woff2?v=4.7.0&#039;. This request has been blocked; the content must be served over HTTPS. (index):1 Mixed Content: The page at &#039;https://forum.tibiaservers.net/&#039; was loaded over HTTPS, but requested an insecure font &#039;http://forum.tibiaservers.net/sites/default/themes/default/fonts/fontawesome-webfont.woff?v=4.7.0&#039;. This request has been blocked; the content must be served over HTTPS._

Hi mate,

@Szmycu I see that you are using Codoforum Version 4.7. Try to update Your CF from CF admin backend to latest version. CF @admin has updated a lot and maybe Your problem is solved after the update.

I had a similar question as you about SSL.

Here You can find the topic: https://codologic.com/forum/index.php?u=/topic/12507/ssl-together-with-codoforum-only-works-limited-help-please

I have no final answer from CF admin about my problem until now. I think our problem is the same, lets wait about what CF @adesh will say about t - he is a very smart developer and I`m sure he know how to fix our issue.

Kind regards, Andy

Hi mate, ------- @Szmycu _**I see that you are using Codoforum Version 4.7. Try to update Your CF from CF admin backend to latest version. CF @admin has updated a lot and maybe Your problem is solved after the update.**_ I had a similar question as you about SSL. **Here You can find the topic:** https://codologic.com/forum/index.php?u=/topic/12507/ssl-together-with-codoforum-only-works-limited-help-please I have no final answer from CF admin about my problem until now. I think our problem is the same, lets wait about what CF @adesh will say about t - he is a very smart developer and I`m sure he know how to fix our issue. Kind regards, Andy

45 years old and still not smarter lol

Check my GitHub Repos: https://github.com/WebCrew

My CrazyMates Account: https://crazymates.de/Crazymate

Cute but Evil Community: https://cute-but-evil.de

edited Dec 10 '19 at 9:28 pm

Hi,

There is still an open bug in rare cases where codoforum is not able to detect whether current website supports https and so it routes the requests to http instead by default.
Other than that, as @WebCrew mentioned, upgrading to the latest version should fix any mixed content issues.

I did visit the forum: https://tibiaservers.net/forum/ but I could not find Mixed content issues there.

Hi, There is still an open bug in rare cases where codoforum is not able to detect whether current website supports https and so it routes the requests to http instead by default. Other than that, as @WebCrew mentioned, upgrading to the latest version should fix any mixed content issues. I did visit the forum: https://tibiaservers.net/forum/ but I could not find Mixed content issues there.
Necessity is the mother of all inventions!

@admin

You can try to run Your whole script (CodoForum) to "Scrutinizer". There is a demo version of it and its a great tool to check your whole source code even with auto debugging etc.

https://scrutinizer-ci.com/login

FEATURES

Scrutinizer supports various analysis tools, processes their results and provides you with a summary like:

  • the newly found issues,
  • evaluates failure conditions,
  • filters false-positives,
  • code rating,
  • automated patches,
  • and provides additional help for certain issues.

  • Continously measure and track code quality

  • Eliminate bugs before they hit production
  • Code metrics simplified and easy to understand
  • Feedback on code quality changes between versions
  • Receive weekly code quality reports

Maybe this will help You to find the last little beats inside Your awesome script and to get rid of bugs like the one with the complicated SSL issue.

Regards, Andy

@admin You can try to run Your whole script (CodoForum) to &quot;Scrutinizer&quot;. There is a demo version of it and its a great tool to check your whole source code even with auto debugging etc. [https://scrutinizer-ci.com/login](https://scrutinizer-ci.com/login &quot;https://scrutinizer-ci.com/login&quot;) **FEATURES** Scrutinizer supports various analysis tools, processes their results and provides you with a summary like: - the newly found issues, - evaluates failure conditions, - filters false-positives, - code rating, - **automated patches**, - and provides additional help for certain issues. - Continously measure and track code quality - **Eliminate bugs** before they hit production - Code metrics simplified and easy to understand - Feedback on code quality changes between versions - Receive weekly code quality reports Maybe this will help You to find the last little beats inside Your awesome script and to get rid of bugs like the one with the complicated SSL issue. Regards, Andy

45 years old and still not smarter lol

Check my GitHub Repos: https://github.com/WebCrew

My CrazyMates Account: https://crazymates.de/Crazymate

Cute but Evil Community: https://cute-but-evil.de

edited Dec 14 '19 at 2:52 am

Hi,

Thanks for the link. We will give it a try.

Hi, Thanks for the link. We will give it a try.
Necessity is the mother of all inventions!

Hi guys! Can someone help me find local forums for developers in my area? I tried to find some refining search with my zip code https://worldpostalcode.com/united-states/texas/houston and failed. It would be good to organize some meetings in real-time to share experience and just communicate. What do you say? If someone is keen on such a project, let’s develop it together. Send me an email if you would like to take part in it.

Hi guys! Can someone help me find local forums for developers in my area? I tried to find some refining search with my zip code [https://worldpostalcode.com/united-states/texas/houston](https://worldpostalcode.com/united-states/texas/houston &quot;https://worldpostalcode.com/united-states/texas/houston&quot;) and failed. It would be good to organize some meetings in real-time to share experience and just communicate. What do you say? If someone is keen on such a project, let&rsquo;s develop it together. Send me an email if you would like to take part in it.
edited Jan 4 at 6:20 pm
100
5
4
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft