Codoforum related discussions
SSL together with CodoForum only works "limited" - help please

@admin @adesh

Hello Adesh.

I use an SSL certificate on my domain and together with Codoforum, I unfortunately get the message that the SSL together with CF only works limited - so there are probably files or scripts which are not offered or integrated via SSL or secure enough.

Can it be that the FreiChat server of you does not run on SSL?

If so, here is a tip:

There is a free really good SSL certificate that anyone who has SSH or shell access can easily activate and use for free. The provider is part of the Linux Open Source distribution and calls itself Let's Encrypt - maybe that would be something for you at Codologic?

Here is the link to Lets Encrypt Service:
https://letsencrypt.org

Kind regards, Andy

@admin @adesh Hello Adesh. I use an SSL certificate on my domain and together with Codoforum, I unfortunately get the message that the SSL together with CF only works **limited** - so there are probably files or scripts which are not offered or integrated via SSL or secure enough. Can it be that the FreiChat server of you does not run on SSL? **If so, here is a tip:** There is a free really good SSL certificate that anyone who has SSH or shell access can easily activate and use for free. The provider is part of the Linux Open Source distribution and calls itself **Let's Encrypt** - maybe that would be something for you at Codologic? **Here is the link to Lets Encrypt Service:** https://letsencrypt.org Kind regards, Andy

44 years old and still not smarter lol

Check my GitHub Repos: https://github.com/WebCrew

My CrazyMates Account: https://crazymates.de/Crazymate

Cute but Evil Community: https://cute-but-evil.de

Hi,

It may be something else because freichat runs on https.

Try checking the network tab in chrome developer tools to see which request is using http

Hi, It may be something else because freichat runs on https. Try checking the network tab in chrome developer tools to see which request is using http
Necessity is the mother of all inventions!

@admin thx for the tip to make use of the developer console, now I found the problem;

Mixed Content: The page at 'https://cute-but-evil.de/board/index.php?u=/user/profile' was loaded over HTTPS, but requested an insecure image ''. This content should also be served over HTTPS.

Mixed Content: The page at 'https://cute-but-evil.de/board/index.php?u=/user/profile' was loaded over HTTPS, but requested an insecure image ''. This content should also be served over HTTPS.

These images are from codo pm (freichat) friend list - only the avatar images of the codopm friend list are not SSL ready - what to do now?

Kind regards, Andy

@admin thx for the tip to make use of the developer console, now I found the problem; Mixed Content: The page at 'https://cute-but-evil.de/board/index.php?u=/user/profile' was loaded over HTTPS, but requested an insecure image 'http://cute-but-evil.de/board/sites/default/assets/img/profiles/5d3b1ba7afdea.png'. This content should also be served over HTTPS. Mixed Content: The page at 'https://cute-but-evil.de/board/index.php?u=/user/profile' was loaded over HTTPS, but requested an insecure image 'http://cute-but-evil.de/board/sites/default/assets/img/profiles/5d110cb7a3663.jpg'. This content should also be served over HTTPS. **These images are from codo pm (freichat) friend list - only the avatar images of the codopm friend list are not SSL ready - what to do now?** Kind regards, Andy

44 years old and still not smarter lol

Check my GitHub Repos: https://github.com/WebCrew

My CrazyMates Account: https://crazymates.de/Crazymate

Cute but Evil Community: https://cute-but-evil.de

edited Nov 15 at 11:48 am

Hi what kind of web-server do you use?
The right way is to configure the server to redirect all http to https.

Hi what kind of web-server do you use? The right way is to configure the server to redirect all http to https.
Necessity is the mother of all inventions!

@admin @adesh

my server configurations are (I have a shared hosting):

Apache Server with a 75 Gig SSD drive & 1024 Mb Ram
PHP-Version: 5.6, to 7.3
Perl-Version: 5.20
MySQL-Version: 5.7.19
and I can protect my domains with a Let's Encrypt or a Sectigo SSL

My hosting also give me the option to forward http to https which I already setup and be using (check the screenshot pls):

5dd1ec2baa2d6
(Ein is the german word for on)

Kind regards, Andy

P.S.: Those unsave avatar images got uploded before I was using SSL - maybe thats the problem?

@admin @adesh my server configurations are (I have a shared hosting): Apache Server with a 75 Gig SSD drive & 1024 Mb Ram PHP-Version: 5.6, to **7.3** Perl-Version: **5.20** MySQL-Version: **5.7.19** and I can protect my domains with a **Let's Encrypt** or a **Sectigo SSL** My hosting also give me the option **to forward http to https** which I already setup and be using (check the screenshot pls): ![5dd1ec2baa2d6](serve/attachment&path=5dd1ec2baa2d6) (**Ein** is the german word for **on**) Kind regards, Andy P.S.: Those unsave avatar images got uploded before I was using SSL - maybe thats the problem?

44 years old and still not smarter lol

Check my GitHub Repos: https://github.com/WebCrew

My CrazyMates Account: https://crazymates.de/Crazymate

Cute but Evil Community: https://cute-but-evil.de

edited Nov 21 at 1:01 am
57
4
2
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft