Codoforum related discussions
SMTP and mail not working

@admin
At the first attempt I received a mail from google saying that this is a less secure app and I need to create a app password for this action. I created one and its still not working but now i didn't receive email regarding this "less secure app". Then I changed from SMTP to mail() but its not working. :c
mail() attempt:
5db9b8516a44f
SMTP attempt: (SMTP connection failed)
5db9b8517e075

@admin At the first attempt I received a mail from google saying that this is a less secure app and I need to create a app password for this action. I created one and its still not working but now i didn't receive email regarding this "less secure app". Then I changed from SMTP to mail() but its not working. :c mail() attempt: ![5db9b8516a44f](serve/attachment&path=5db9b8516a44f) SMTP attempt: (SMTP connection failed) ![5db9b8517e075](serve/attachment&path=5db9b8517e075)
edited Oct 30 at 4:58 pm

Hi,

Gmail has made its SMTP authentication more strict. You will have to do two things:

Open security checkup : https://myaccount.google.com/u/1/security-checkup

There it will probably show a critical issue saying there was a recent sign in from a server (your server)
You need to say it was you and allow access.

Then you need to allow access from 3rd party apps by enabling this setting:
https://myaccount.google.com/u/1/lesssecureapps

If you have multiple gmail accounts, make sure you are doing above steps using the account that you have configured in codoforum.


Another thing you can try is change protocol to tls and port to 587

Hi, Gmail has made its SMTP authentication more strict. You will have to do two things: Open security checkup : https://myaccount.google.com/u/1/security-checkup There it will probably show a critical issue saying there was a recent sign in from a server (your server) You need to say it was you and allow access. Then you need to allow access from 3rd party apps by enabling this setting: https://myaccount.google.com/u/1/lesssecureapps If you have multiple gmail accounts, make sure you are doing above steps using the account that you have configured in codoforum. --- Another thing you can try is change protocol to tls and port to 587
Necessity is the mother of all inventions!
edited Oct 30 at 5:49 pm

Google's APIs and other Google services are becoming more and more chaotic and cluttered. Where other vendors try to provide the most customer-friendly solution for their customers, Google seems to be doing exactly the opposite smile

I also had to adjust my SMTP settings and after a few failed attempts I`m now actually done, even if I suspect that my beard has now got even more gray hair smile

Google's APIs and other Google services are becoming more and more chaotic and cluttered. Where other vendors try to provide the most customer-friendly solution for their customers, Google seems to be doing exactly the opposite :) I also had to adjust my SMTP settings and after a few failed attempts I`m now actually done, even if I suspect that my beard has now got even more gray hair :)

42 years old and still not smarter lol

MyGitHub: https://github.com/WebCrew

CrazyMates Homepage: https://crazymates.de/Crazymate

I tried to help our friend yesterday and made it working on my installation by changing the Mail Type to Mail(), instead of SMTP.

Worked for me and not facing any issues. I did received the security warning by Google, but the system worked.

Unfortunatelly it didn't worked for @Attila smile

I'll now double check my Google Security settings to avoid future surprises.

I tried to help our friend yesterday and made it working on my installation by changing the Mail Type to **Mail()**, instead of SMTP. Worked for me and not facing any issues. I did received the security warning by Google, but the system worked. Unfortunatelly it didn't worked for @Attila ;( I'll now double check my Google Security settings to avoid future surprises.

BlackBerry enthusiast, entrepreneur, web developer, geek with glasses and enlightened agent!

I also had some fights with the Google security system to get my SMTP running again, but now it does. The PHP Mail() option is sadly not working for me with my Google mail address.

To bad that Google does see our apps as security risk - at the end it should be the app owners decision if we want to make use of a bit of a insecure app or not, but thats Google - it becomes more and more a Dictator company smile

I also had some fights with the Google security system to get my SMTP running again, but now it does. The PHP Mail() option is sadly not working for me with my Google mail address. To bad that Google does see our apps as security risk - at the end it should be the app owners decision if we want to make use of a bit of a insecure app or not, but thats Google - it becomes more and more a Dictator company :(

42 years old and still not smarter lol

MyGitHub: https://github.com/WebCrew

CrazyMates Homepage: https://crazymates.de/Crazymate

edited Oct 31 at 10:08 pm
44
4
4
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft