Codoforum related discussions
SSL Mismatch Error

Hello, I am trying to setup a SSL certificate that works fine with everything except Codoforum.

I contacted my hosting provider that stated I was having a SSL mismatch error.

Hi Adam,

Yes, this would be due to what is known as Mixed SSL content. I'll try to explain what's causing this issue in the best way that I can, however, I can see you're using Codoforum, which I don't have any experience with, so I might not be able to personally rectify this issue.

To make a site fully secure with SSL/HTTPS, all content needs to be sent over it, such as images, CSS/JS files and any other content which is being displayed. This means that all links to images and CSS/JS files must start with 'https://' prefix.

In the case of 'www.lightningworks.services', this is working perfectly fine, however, with 'www.lightningworks.services/marketplace', it seems to be sending some content over a non-SSL connection (this means the links start with the 'http://' prefix), which causes most browsers to display a warning. The error/warnings can be seen here -

Would you like me to try to rectify this myself, otherwise I would suggest it would be worth contacting their support?

Kind Regards,
Harry P

Director
OptNode Hosting

He told me later on to contact this support because he wasn't very familiar with Codoforum so does anyone know a solution?

Hello, I am trying to setup a SSL certificate that works fine with everything except Codoforum. I contacted my hosting provider that stated I was having a SSL mismatch error. Hi Adam, Yes, this would be due to what is known as Mixed SSL content. I'll try to explain what's causing this issue in the best way that I can, however, I can see you're using Codoforum, which I don't have any experience with, so I might not be able to personally rectify this issue. To make a site fully secure with SSL/HTTPS, all content needs to be sent over it, such as images, CSS/JS files and any other content which is being displayed. This means that all links to images and CSS/JS files must start with 'https://' prefix. In the case of 'www.lightningworks.services', this is working perfectly fine, however, with 'www.lightningworks.services/marketplace', it seems to be sending some content over a non-SSL connection (this means the links start with the 'http://' prefix), which causes most browsers to display a warning. The error/warnings can be seen here - https://cdn.majored.me/file-sharing/png/36awr.png Would you like me to try to rectify this myself, otherwise I would suggest it would be worth contacting their support? Kind Regards, Harry P Director OptNode Hosting He told me later on to contact this support because he wasn't very familiar with Codoforum so does anyone know a solution?

Hi,

Can you click on the number 21 and check which urls are being loaded on http ?
If they are related to codoforum, we can fix them.

Hi, Can you click on the number 21 and check which urls are being loaded on http ? If they are related to codoforum, we can fix them.
Necessity is the mother of all inventions!
52
2
3
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft