Show Categories
375
3
sticky

what's new in [4.9.1]

  • Fixed compatibility issues with PHP 7.4
  • Notifications tab fix in edit profile
  • Preferences style fix
  • Smiley fix for forum posts
  • Update jquery nestable plugin
  • Vintage theme template and css fixes
  • Security fix in admin category
  • Fixed draggable not working for nested categories
  • Edit avatar fix for firefox

There will be another release(4.9.2) within the next week or two, for a few bug fixes.

The upcoming major revision [5.0], will have some major improvements,

  • We plan to separate cache and uploaded asset storage and code.
  • Some re-structuring to make the code look modern and standard so as to make it easier for people coming for other frameworks to make changes easily.
  • We do plan to keep things backwards compatible and hope to make it a one click upgrade.

Solve below & any other pending bugs from forum:

PS: Thanks to all the contributors, community members and our well wishers, your feedback and appreciation keeps us going smile

Happy Easter!
Stay Home. Stay Safe.

recent by david_nash  ·  Apr 29 at 4:39 am
1.2k
5
sticky
WebCrew posted Aug 30 '19 at 1:03 am

Hallo Community

because there is no dark theme (style) for Codoforum I created one for myself and I share the result now with the Codo community.

I am not a professional webdesign artist or developer. It is one of my hobbies and even if I love webdesign and already created a lot of projects, I`m sure the theme is far from perfect but it is ready to use.

If You like it or download it give me a thumbs up or leave a comment.

I try to update the theme from time to time and maybe I will integrate some new features too.

Here is the download link:

Kind Regards, Andy

5d6866b05ef1a


5d6866b05ef1a
recent by Andy4real  ·  Apr 8 at 11:59 am
595
5
sticky
admin posted Jan 6 at 9:39 pm

We have had a few contributors on this forum through the last 5+ years.

So we have decided to announce contributions every month:

@WebCrew
Thank you for your continuous contributions throughout the time. Not only does he help people on the forum, he also contributes directly by sending code and valuable suggestions.

Prasanth c41m
Thank you for your recent contributions and advance notification regarding the recent exploit that you encountered in Codoforum. [We will add more detail here once the patch is out]

recent by quenquen  ·  Apr 1 at 5:02 pm
287
7
Gokhan Krl posted Dec 5 '18 at 11:39 am

Getting error after installation.

Fatal error: Uncaught Error: Class 'Smarty_Internal_Undefined' not found in /opt/lampp/htdocs/topluluk/sys/Ext/Smarty/sysplugins/smarty_internal_extension_handler.php:164 Stack trace: #0 /opt/lampp/htdocs/topluluk/sys/Ext/Smarty/Smarty.class.php(992): Smarty_Internal_Extension_Handler->__get('loadPlugin') #1 /opt/lampp/htdocs/topluluk/sys/Ext/Smarty/sysplugins/smarty_internal_template.php(627): Smarty->loadPlugin('Smarty_Internal...') #2 /opt/lampp/htdocs/topluluk/sys/Ext/Smarty/sysplugins/smarty_template_compiled.php(183): Smarty_Internal_Template->loadCompiler() #3 /opt/lampp/htdocs/topluluk/sys/Ext/Smarty/sysplugins/smarty_template_compiled.php(141): Smarty_Template_Compiled->compileTemplateSource(Object(Smarty_Internal_Template)) #4 /opt/lampp/htdocs/topluluk/sys/Ext/Smarty/sysplugins/smarty_template_compiled.php(105): Smarty_Template_Compiled->process(Object(Smarty_Internal_Template)) #5 /opt/lampp/htdocs/topluluk/sys/Ext/Smarty/sysplugins/smarty_internal_template.php(206): Smarty_Template_Compiled->render(Object(Sma in /opt/lampp/htdocs/topluluk/sys/Ext/Smarty/sysplugins/smarty_internal_extension_handler.php on line 164
recent by EvgenDriplo  ·  May 20 at 9:31 pm
23
1
ferdi posted May 11 at 11:37 am

Hello, I installed codoforum on localhost. But even though I set htaccess, sef url doesn't work. And it is constantly moving like this: index.php?u=. Is there a way to fix this?

Note: Mod_rewrite is enabled.

Thank you.

recent by admin  ·  May 14 at 6:49 pm
87
13

Hello

I'm having issues with the Mail Notify plugin and the mail queue.

I have a user who's been getting the same email repeatedly.

I tracked down the issue to sys/CODOF/Forum/Notication/MailQueue.php on line 43:

$qry = 'DELETE FROM ' . PREFIX . 'codo_mail_queue WHERE id IN (' . $_ids . ')';

I believe the PREFIX or the codo_ should be there, but not both.

I also seem to be having an issue where none of my users are getting notified of posts, but I need to look into my mail logs to track that one down.

bug
recent by admin  ·  May 14 at 6:49 pm
54
4
Tango posted May 10 at 9:47 pm

Hello,

I'm having an error as you can see in the attached SS.

Way to reproduce:

  1. Fresh install Codoforum
  2. Delete all Categories
  3. Create new category
  4. View it on front (the page styling will be broken)

I'm using:

  • Codoforum 4.9.3
  • PHP 7.3.6
  • MySQL: 5.7.30

5eb868262cd82

Codoforum has the same issue:

5eb86a2fc1ef1


5eb868262cd82
recent by admin  ·  May 14 at 4:09 pm
19
1
msteinruck posted May 11 at 1:49 am

I recently installed Codoforum for the first time. The installation was flawless, but when I turn on the option for reCaptcha and try registering a test account, I get this error:

{domain-sys-path}]/html/sys/Ext/recaptcha/recaptchalib.php on line 40

Warning: file_get_contents(): {https}:// wrapper is disabled in the server configuration by allow_url_fopen=0 in {domain-sys-path}/html/sys/Ext/recaptcha/recaptchalib.php on line 88

Warning: file_get_contents({google-recaptcha-path}: failed to open stream: no suitable wrapper could be found in {domain-sys-path}/html/sys/Ext/recaptcha/recaptchalib.php on line 88

Warning: Use of undefined constant error - assumed 'error' (this will throw an Error in a future version of PHP) in {domain-sys-path}/html/sys/Ext/recaptcha/recaptchalib.php on line 124

Warning: Use of undefined constant codes - assumed 'codes' (this will throw an Error in a future version of PHP) in {domain-sys-path}/html/sys/Ext/recaptcha/recaptchalib.php on line 124

Warning: A non-numeric value encountered in {domain-sys-path}/html/sys/Ext/recaptcha/recaptchalib.php on line 124

Warning: A non-numeric value encountered in {domain-sys-path}/html/sys/Ext/recaptcha/recaptchalib.php on line 124

I'm at a loss of what would be causing this. Can someone help me troubleshoot?

recent by WebCrew  ·  May 13 at 5:08 am
27
2

Anyone who has the "users" role is not able to see anything including the homepage. It will just auto-redirect them to there own profile. If they try to make a new topic it says the page is not found. The "Users" role permissions is as follows.
5eba1885bc00b
5eba197e1cba6

If I make a new role and have it copy permissions for "Users" and apply it to a test account, it will allow the test account to view categories and see the make a post. If I just have it set to the "Users" role it can't. I tried setting the user's role to nothing, saving, then setting it back to no change.

Anyone have had this issue and know a fix?


5eba1885bc00b
recent by blockgaming  ·  May 12 at 9:17 pm
73
7
AlexaFers posted Mar 27 at 1:42 am

helo,i have a problem with the role action.

I try to login with user and working as usually,but even i try to go to the main page on index.php i got problem with the role of user,administrator but even i try using the moderator role its working and nothing problem happened.Please ur attention guys.Thanks

bug
16
1
blockgaming posted May 8 at 5:12 am

When a user changes there password, requests a password reset, changes account info, deletes a post, and so on Codoforum should log the action in some page in the /admin page with stuff like browser agent, IP, and time/date, account, and so on.

recent by admin  ·  May 8 at 9:58 am
18
0

Hello, i have a website which using humhub and i have tested your freichat add-on in it (without many options).

I am interesting to add your business version in my website but i would like to see more screenshots of this one ; is it possible to have it by mail please ?

Regards

53
4

Hi Community smile

If You want that Your users will get redirected to the forum home and not to profile page then follow my simple tutorial, please.

  • To edit the following file use a code Editor like Notepad++ or Sublimem both are free):

  • Open: codoforum\sites\default\themes\default\templates\user*login.tpl
    Go to
    line number 161 and replace the default code - this one*
    :

window.location.href = codo_defs.url + 'user/profile';
  • with that one:
window.location.href = codo_defs.url;
  • Now save, upload the file, recache browser and it should do the trick.

Kind regards,

Andy


P.S.: If You are using a other Codoforum theme, make sure to check if there is a login.tpl included (if not then all is fine). If yes then do the same with that template, please.

recent by admin  ·  May 6 at 10:20 am
184
15

Hello to all.

I'm new here and thank you for the attention beforehand.

The forum was working correctly until today but, "suddently" (I haven't changed the code today) users couldn't see the home page where all the topics are listed. The users are constantly redirected to the Profile page where their created topics appear. These topics cannot be accessed even by their creators, returning a "not found" page.

Changing the permissions to admin seems to fix the issue, but creates another one which is, users shouldn't have admin permissions.

I searched here but couldn't find an answer to the problem. If anyone could help me, I'd appreciate it.

Thanks again!

recent by SMPASCO  ·  May 4 at 9:54 pm
325
14

Hello,

So...i've just started using codoforum, wich is a very nice and smooth forum platform, congrats to the developer/s.
I've been editing the default theme to try and create a gaming one, with a slider and other nice features. Here's a preview hope you like it and give some opinions and sugestions.

The template is still in the works, this week should be available on github, i'll update this topic.

Kind regards,
ALCHEM;.

PS: Sorry for my bad english smile


recent by quenquen  ·  May 2 at 6:35 pm
14
1
blockgaming posted May 1 at 6:53 am

A ability for a admin to login as a user on the forums through the admin backpage. This can be used to troubleshoot issues with people's accounts if they arise. This would be done by clicking a button and would not need a password. Or is there a plugin to do this?

recent by admin  ·  May 1 at 10:52 am
53
5

Hi,

I've tried to configure the SSO plugin in a fresh copy of Codo Forum, and it doesn't works.

The steps I've made:

  • Download codoforum.v.4.9.2.zip and unzip
  • Access Install, and follow steps
    • Between step 2 and 3 I've got the error on my log file:
[Mon Apr 27 04:33:42 2020] [warn] [client 193.104.51.88] mod_fcgid: stderr: PHP Fatal error:  Uncaught PDOException: SQLSTATE[HY000] [2002] No such file or directory in /var/www/html/forum/sys/vendor/illuminate/database/Illuminate/Database/Connectors/Connector.php:47, referer: forum.todayis20.com/install/index.php?u=/index.php&step=2
  • If I refresh page, then it works fine (this happened to me the 3 times I've installed the code doing some tests)
  • Go to plugin page and enable SSO. Then upgrade, configure and fill with my data
  • Configure the client.php file in my Auth site.

In this point, when I access to the forum's site I get:

Fatal error: Uncaught Error: Call to a member function addJS() on null in /var/www/html/forum/sys/globals/global.php:136 
Stack trace: 
    #0 /var/www/html/forum/sites/default/plugins/sso/sso.php(109): add_js('forum.to...', Array) 
    #1 [internal function]: add_sso_js(Array, Array) 
    #2 /var/www/html/forum/sys/CODOF/Hook.php(74): call_user_func_array('add_sso_js', Array) 
    #3 /var/www/html/forum/sys/CODOF/Smarty/Layout.php(26): CODOF\Hook::call('before_site_hea...') 
    #4 /var/www/html/forum/routes.php(939): CODOF\Smarty\Layout::load('forum/topics', Array, Array) 
    #5 /var/www/html/forum/sys/Ext/limonade/limonade.php(421): {closure}() 
    #6 /var/www/html/forum/sys/CODOF/Access/Request.php(94): run() 
    #7 /var/www/html/forum/routes.php(952): CODOF\Access\Request::start() 
    #8 /var/www/html/forum/index.php(22): require('/var/www...') 
    #9 {main} thrown in /var/www/html/forum/sys/globals/global.php on line 136

I've tried to remove the error lines and add the js and css on the layout.tpl file, but timestamp errors come to me.

Any advice? smile

Categories
Actions
Hide topic messages
Enable infinite scrolling
All posts under this topic will be deleted ?
Previous
1234 ... 136
Next
Pending draft ... Click to resume editing
Discard draft