Hello,

My forum uses Sinhalese language in Unicode format, sometimes in title too. I have used beautified urls.

Ex: http://example.com/topic/2/මගේ-ෆෝරම්-එක

The problem is whenever I try to click a link generated(with Sinhalese Unicode text) it gives me 404 error.

I have two questions:

  1. Can I remove safe_title from templates and core? Is there a way to do that? If so will it be affected to latest reply urls?
  2. Is there another way to fix this issue?

Thanks in advance.

PS: I'm sorry I cannot replicate the issue as the project is still in my local server. You can try to create the following title for a topic and see how it goes.

''Example.com වෙත සාදරයෙන් පිළිගනිමු - Welcome to example.com"

UPDATE: I found that the error is specially with these two characters: "ළ-"

Hello, My forum uses Sinhalese language in Unicode format, sometimes in title too. I have used beautified urls. Ex: http://example.com/topic/2/මගේ-ෆෝරම්-එක The problem is whenever I try to click a link generated(with Sinhalese Unicode text) it gives me 404 error. I have two questions: 1. Can I remove ```` safe_title ```` from templates and core? Is there a way to do that? If so will it be affected to latest reply urls? 2. Is there another way to fix this issue? Thanks in advance. PS: I'm sorry I cannot replicate the issue as the project is still in my local server. You can try to create the following title for a topic and see how it goes. ''Example.com වෙත සාදරයෙන් පිළිගනිමු - Welcome to example.com" UPDATE: I found that the error is specially with these two characters: "**_ළ-_**"
edited Apr 11 at 12:49 pm
 
0
reply
45
views
0
replies
1
followers
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft