Replacing the code should have been a permanent fix, can you please check your server error logs.

Leaving that, if you want that configuration which you achieved by running the query to remain permanent, open the mysql configuration file, usually present in /etc/mysql/my.cnf

Find the section named [mysql]

You should be able to find ONLY_FULL_GROUP_BY in sql_mode variable, just remove that.
It is a bit confusing, so if you don't understand, send me the file, I will help you with the changes.

Replacing the code should have been a permanent fix, can you please check your server error logs. Leaving that, if you want that configuration which you achieved by running the query to remain permanent, open the mysql configuration file, usually present in /etc/mysql/my.cnf Find the section named [mysql] You should be able to find ONLY_FULL_GROUP_BY in sql_mode variable, just remove that. It is a bit confusing, so if you don't understand, send me the file, I will help you with the changes.
edited Nov 21 '16 at 5:42 pm
 
0
reply

Where and how can I find /etc/mysql/my.cnf ??? I use plesk II

I tried using ssh access with bitvise ssh client I entered there via these commands:

ls /etc/mysql/

sudo vim /etc/mysql/my.cnf

but I have no idea what should I do here... ? can you please give me more details about this?

583358b83ee6f.png

Where and how can I find /etc/mysql/my.cnf ??? I use plesk II I tried using ssh access with bitvise ssh client I entered there via these commands: ```` ls /etc/mysql/ sudo vim /etc/mysql/my.cnf ```` but I have no idea what should I do here... ? can you please give me more details about this? ![583358b83ee6f.png](serve/attachment&path=583358b83ee6f.png)
edited Nov 21 '16 at 8:28 pm
 
0
reply

hello.
you just have to remove ONLY_GROUP_BY, from the line under [mysqld] and restart mysql.

if you are not familiar with vi, move with arrows to the first carater to remove, press 'x' to remove to the first ',', then press ':' and 'x' to save.

my 2 cents...

hello. you just have to remove ONLY_GROUP_BY, from the line under [mysqld] and restart mysql. if you are not familiar with vi, move with arrows to the first carater to remove, press 'x' to remove to the first ',', then press ':' and 'x' to save. my 2 cents...

please, excuse my bad english! ( i'm french, and i know, it's not a good excuse ! ;) )

 
0
reply

If you are finding it difficult you can install nano if it is not already installed.

If you are finding it difficult you can install nano if it is not already installed.
 
0
reply

@adesh1414127033 yeah I installed sudo nano and I succeeded to remove it have a look on it.. but it still doesn't show any notifications?!!?!

The edited code:

#
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - ".my.cnf" to set user-specific options.
#
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html

#
# * IMPORTANT: Additional settings that can override those from this file!
#   The files must end with '.cnf', otherwise they'll be ignored.
#

!includedir /etc/mysql/conf.d/
!includedir /etc/mysql/mysql.conf.d/
[mysqld]

bind-address = ::ffff:127.0.0.1
local-infile=0

The previous not-edited code was like this:

#
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - ".my.cnf" to set user-specific options.
#
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html

#
# * IMPORTANT: Additional settings that can override those from this file!
#   The files must end with '.cnf', otherwise they'll be ignored.
#

!includedir /etc/mysql/conf.d/
!includedir /etc/mysql/mysql.conf.d/
[mysqld]
sql_mode=ONLY_FULL_GROUP_BY,NO_ZERO_IN_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION
bind-address = ::ffff:127.0.0.1
local-infile=0

thanks a lot for everything!

@adesh1414127033 yeah I installed sudo nano and I succeeded to remove it have a look on it.. but it still doesn't show any notifications?!!?! The edited code: ```` # # The MySQL database server configuration file. # # You can copy this to one of: # - "/etc/mysql/my.cnf" to set global options, # - "~/.my.cnf" to set user-specific options. # # One can use all long options that the program supports. # Run program with --help to get a list of available options and with # --print-defaults to see which it would actually understand and use. # # For explanations see # http://dev.mysql.com/doc/mysql/en/server-system-variables.html # # * IMPORTANT: Additional settings that can override those from this file! # The files must end with '.cnf', otherwise they'll be ignored. # !includedir /etc/mysql/conf.d/ !includedir /etc/mysql/mysql.conf.d/ [mysqld] bind-address = ::ffff:127.0.0.1 local-infile=0 ```` The previous not-edited code was like this: ```` # # The MySQL database server configuration file. # # You can copy this to one of: # - "/etc/mysql/my.cnf" to set global options, # - "~/.my.cnf" to set user-specific options. # # One can use all long options that the program supports. # Run program with --help to get a list of available options and with # --print-defaults to see which it would actually understand and use. # # For explanations see # http://dev.mysql.com/doc/mysql/en/server-system-variables.html # # * IMPORTANT: Additional settings that can override those from this file! # The files must end with '.cnf', otherwise they'll be ignored. # !includedir /etc/mysql/conf.d/ !includedir /etc/mysql/mysql.conf.d/ [mysqld] sql_mode=ONLY_FULL_GROUP_BY,NO_ZERO_IN_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION bind-address = ::ffff:127.0.0.1 local-infile=0 ```` thanks a lot for everything!
 
0
reply

the file should be :

!includedir /etc/mysql/conf.d/
!includedir /etc/mysql/mysql.conf.d/
[mysqld]
sql_mode=NO_ZERO_IN_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION
bind-address = ::ffff:127.0.0.1
local-infile=0

did you restart mysql ?
any .my.cnf file elsewhere ?
nothing in included dir ?

can you verify with

ls -al ~/.my.cnf

for user config file and

sudo grep -ir 'ONLY_GROUP_BY' /etc/mysql

for something wrong in included files ?

the file should be : ```` !includedir /etc/mysql/conf.d/ !includedir /etc/mysql/mysql.conf.d/ [mysqld] sql_mode=NO_ZERO_IN_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION bind-address = ::ffff:127.0.0.1 local-infile=0 ```` did you restart mysql ? any .my.cnf file elsewhere ? nothing in included dir ? can you verify with ```` ls -al ~/.my.cnf ```` for user config file and ```` sudo grep -ir 'ONLY_GROUP_BY' /etc/mysql ```` for something wrong in included files ?

please, excuse my bad english! ( i'm french, and i know, it's not a good excuse ! ;) )

edited Nov 24 '16 at 2:47 pm
 
0
reply

and finally it worked!!!!! GOOD NEWS!!!

thanks @adesh1414127033 and to @phig330

I used this code:

!includedir /etc/mysql/conf.d/
!includedir /etc/mysql/mysql.conf.d/
[mysqld]
sql_mode=NO_ZERO_IN_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION
bind-address = ::ffff:127.0.0.1
local-infile=0

You are brilliant I will start building my team now and having a great educational site!!! Millions of thanks (Y) you are the best

and finally it worked!!!!! GOOD NEWS!!! thanks @adesh1414127033 and to @phig330 I used this code: ```` !includedir /etc/mysql/conf.d/ !includedir /etc/mysql/mysql.conf.d/ [mysqld] sql_mode=NO_ZERO_IN_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION bind-address = ::ffff:127.0.0.1 local-infile=0 ```` You are brilliant I will start building my team now and having a great educational site!!! Millions of thanks (Y) you are the best
 
0
reply

@phig330 pls can you explain more on how to get mention notification working. Tnx

@phig330 pls can you explain more on how to get mention notification working. Tnx
 
0
reply

hello.
can you please open a new topic, or at least post more informations ? ( php/mysql versions, error messages in logs, url of your forum ...).

notifications must work out of the box.

thx

hello. can you please open a new topic, or at least post more informations ? ( php/mysql versions, error messages in logs, url of your forum ...). notifications must work out of the box. thx

please, excuse my bad english! ( i'm french, and i know, it's not a good excuse ! ;) )

 
0
reply
12
416
views
29
replies
4
followers
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft