Codoforum related discussions
Possible to update from V.4.9.4 to V.5.2.1 ?

I just try to update old forum from V.4.9.4 to V.5.2.1 it shows the update in admin dashboard but it always say i have latest version install when i click to update:
6344824e08b0f




1.0> Checking for latest version
1.1> Connecting to server: codoforum.com ...
####: Initiating cURL request
1.3> Response:
Raw: 4.9.4|codoforum.v.4.9.4.patch.zip|8b334fe843117e3e5c8c3d856dbb858d
Latest version is 4.9.4
File to be downloaded to cache dir: codoforum.v.4.9.4.patch.zip
You are using the latest version :)

Can i force update in a way or run it manually in the filesystem?


I just try to update old forum from V.4.9.4 to V.5.2.1 it shows the update in admin dashboard but it always say i have latest version install when i click to update: ![6344824e08b0f](serve/attachment&path=6344824e08b0f) > ```` 1.0> Checking for latest version 1.1> Connecting to server: codoforum.com ... ####: Initiating cURL request 1.3> Response: Raw: 4.9.4|codoforum.v.4.9.4.patch.zip|8b334fe843117e3e5c8c3d856dbb858d Latest version is 4.9.4 File to be downloaded to cache dir: codoforum.v.4.9.4.patch.zip You are using the latest version :) ```` Can i force update in a way or run it manually in the filesystem?

https://github.com/killajoe

Do You have at least PHP Version 7.0 ? If not - You need it.
Can you also check for any error messages at Google Chrome Developer Console and share them with us please.


Kind regards, WebCrew smile


Do You have at least PHP Version 7.0 ? If not - You need it. Can you also check for any error messages at Google Chrome Developer Console and share them with us please. Kind regards, WebCrew ;)

Join: Net-Twin Community

Visit my GitHub: @WebCrew

Hi


Unfortunately, It is not possible to update to v5.2.x from versions below it from the upgrade manager.


This is because till 5.1 code is not compatible with PHP 8 and 5.2 has lot of rewrite to support the latest version of PHP 8 which is not supported on lower versions of PHP.


So if we allowed anyone to upgrade it to latest version it would break the forum so we disabled it.


You have to first ensure you have the latest PHP version, then manually replace codoforum folder with latest files except sites/default/config.php (make sure to keep backup of your old codoforum as that will have your images and other assets)


Since database changes are minimal and compatible you won't lose any data.


Hi Unfortunately, It is not possible to update to v5.2.x from versions below it from the upgrade manager. This is because till 5.1 code is not compatible with PHP 8 and 5.2 has lot of rewrite to support the latest version of PHP 8 which is not supported on lower versions of PHP. So if we allowed anyone to upgrade it to latest version it would break the forum so we disabled it. You have to first ensure you have the latest PHP version, then manually replace codoforum folder with latest files except sites/default/config.php (make sure to keep backup of your old codoforum as that will have your images and other assets) Since database changes are minimal and compatible you won't lose any data.
Necessity is the mother of all inventions!
29
2
3
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft