General discussion
Cannot access forum, uncaught PDOException

When I try to access the forum in my VM, the below error is shown at every webpage I attempt to enter.


Fatal error: Uncaught PDOException: PDO::__construct(): php_network_getaddresses: getaddrinfo failed: Temporary failure in name resolution in /var/www/codoforum/sys/vendor/illuminate/database/Illuminate/Database/Connectors/Connector.php:47 Stack trace: #0 /var/www/codoforum/sys/vendor/illuminate/database/Illuminate/Database/Connectors/Connector.php(47): PDO->__construct() #1 /var/www/codoforum/sys/vendor/illuminate/database/Illuminate/Database/Connectors/MySqlConnector.php(20): Illuminate\Database\Connectors\Connector->createConnection() #2 /var/www/codoforum/sys/vendor/illuminate/database/Illuminate/Database/Connectors/ConnectionFactory.php(57): Illuminate\Database\Connectors\MySqlConnector->connect() #3 /var/www/codoforum/sys/vendor/illuminate/database/Illuminate/Database/Connectors/ConnectionFactory.php(46): Illuminate\Database\Connectors\ConnectionFactory->createSingleConnection() #4 /var/www/codoforum/sys/vendor/illuminate/database/Illuminate/Database/DatabaseManager.php(176): Illuminate\Database\Connectors\Connectio in /var/www/codoforum/sys/vendor/illuminate/database/Illuminate/Database/Connectors/Connector.php on line 47

I haven't made any changes to the forum prior to getting this error and I am not sure what may be causing this issue.


When I try to access the forum in my VM, the below error is shown at every webpage I attempt to enter. ```` Fatal error: Uncaught PDOException: PDO::__construct(): php_network_getaddresses: getaddrinfo failed: Temporary failure in name resolution in /var/www/codoforum/sys/vendor/illuminate/database/Illuminate/Database/Connectors/Connector.php:47 Stack trace: #0 /var/www/codoforum/sys/vendor/illuminate/database/Illuminate/Database/Connectors/Connector.php(47): PDO->__construct() #1 /var/www/codoforum/sys/vendor/illuminate/database/Illuminate/Database/Connectors/MySqlConnector.php(20): Illuminate\Database\Connectors\Connector->createConnection() #2 /var/www/codoforum/sys/vendor/illuminate/database/Illuminate/Database/Connectors/ConnectionFactory.php(57): Illuminate\Database\Connectors\MySqlConnector->connect() #3 /var/www/codoforum/sys/vendor/illuminate/database/Illuminate/Database/Connectors/ConnectionFactory.php(46): Illuminate\Database\Connectors\ConnectionFactory->createSingleConnection() #4 /var/www/codoforum/sys/vendor/illuminate/database/Illuminate/Database/DatabaseManager.php(176): Illuminate\Database\Connectors\Connectio in /var/www/codoforum/sys/vendor/illuminate/database/Illuminate/Database/Connectors/Connector.php on line 47 ```` I haven't made any changes to the forum prior to getting this error and I am not sure what may be causing this issue.

So it seems like this error is coming from the PDO statement creation from the createConnection function.


How would I be able to trace back the parameters that might be giving the problem? (Sorry I don't have programmatic knowledge in PHP to be able to debug this myself.)


So it seems like this error is coming from the PDO statement creation from the createConnection function. How would I be able to trace back the parameters that might be giving the problem? (Sorry I don't have programmatic knowledge in PHP to be able to debug this myself.)

Hi


What parameter did you give for host when you tried installing?


Hi What parameter did you give for host when you tried installing?
Necessity is the mother of all inventions!

I'm not quite sure as this particular instance wasn't installed by me. I do have access to the VM where the DB is installed in case it is stored within there.


I'm not quite sure as this particular instance wasn't installed by me. I do have access to the VM where the DB is installed in case it is stored within there.

It will be difficult to identify the root cause.
Why not install codoforum via docker? We do have a directly installable docker image.


It's not intended for production use but you can atleast test out the features.


It will be difficult to identify the root cause. Why not install codoforum via docker? We do have a directly installable docker image. It's not intended for production use but you can atleast test out the features.
Necessity is the mother of all inventions!

Reinstalling should be no problem. My only concern would be whether the posts made on the non-working environment can be preserved and clone to a new one.


Would this be accomplishable by cloning the DB and the image files that were are linked to the DB to a new forum environment?


Reinstalling should be no problem. My only concern would be whether the posts made on the non-working environment can be preserved and clone to a new one. Would this be accomplishable by cloning the DB and the image files that were are linked to the DB to a new forum environment?

If it's also Codoforum then you should be able to import your old post table into the new database - I think that will work.


Kind regards, WebCrew smile


If it's also Codoforum then you should be able to import your old post table into the new database - I think that will work. Kind regards, WebCrew :)

Join: Net-Twin Community

Visit my GitHub: @WebCrew

62
7
3
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft