Codoforum related discussions
User having problems to see posts

Hello to all.

I'm new here and thank you for the attention beforehand.

The forum was working correctly until today but, "suddently" (I haven't changed the code today) users couldn't see the home page where all the topics are listed. The users are constantly redirected to the Profile page where their created topics appear. These topics cannot be accessed even by their creators, returning a "not found" page.

Changing the permissions to admin seems to fix the issue, but creates another one which is, users shouldn't have admin permissions.

I searched here but couldn't find an answer to the problem. If anyone could help me, I'd appreciate it.

Thanks again!

Hello to all. I'm new here and thank you for the attention beforehand. The forum was working correctly until today but, "suddently" (I haven't changed the code today) users couldn't see the home page where all the topics are listed. The users are constantly redirected to the Profile page where their created topics appear. These topics cannot be accessed even by their creators, returning a "not found" page. Changing the permissions to admin seems to fix the issue, but creates another one which is, users shouldn't have admin permissions. I searched here but couldn't find an answer to the problem. If anyone could help me, I'd appreciate it. Thanks again!

Hi,

Is your forum set to private in backend -> Global settings? Try setting "Who can access forum" to "Everyone"

Hi, Is your forum set to private in backend -> Global settings? Try setting "Who can access forum" to "Everyone"
Necessity is the mother of all inventions!

It is. After seeing your response I tried setting it to "registered users", didn't seem to solve. Going back to "Everyone" didn't change too.

It keeps redirecting the user to "index.php?u=/user/profile"

It is. After seeing your response I tried setting it to "registered users", didn't seem to solve. Going back to "Everyone" didn't change too. It keeps redirecting the user to "index.php?u=/user/profile"

Hi,

Can you give the url to your forum with admin details?
You can send them to admin[@]codologic.com

Hi, Can you give the url to your forum with admin details? You can send them to admin[@]codologic.com
Necessity is the mother of all inventions!

Just installed and EXACT same error is happening. Error only showed up after I added a test user. User now deleted and still frontend redirects to "index.php?u=/user/profile". No difference when changing Global Settings to Everyone

Just installed and EXACT same error is happening. Error only showed up after I added a test user. User now deleted and still frontend redirects to "index.php?u=/user/profile". No difference when changing Global Settings to Everyone

Hi ChampAgain,

Managed to fix this.

Login to the Admin backend.

Go to Manage Users > Edit for your user.

Ensure Primary Role pulldown is set to Administrator.

Ensure Role Checkboxes for USER / MODERATOR / ADMINISTRATOR are all checked and save changes.

THAT fixed it for me!

Hi ChampAgain, Managed to fix this. Login to the Admin backend. Go to **Manage Users > Edit** for your user. Ensure Primary Role pulldown is set to Administrator. Ensure Role Checkboxes for USER / MODERATOR / ADMINISTRATOR are all checked and save changes. THAT fixed it for me!

Having the same issue!

I've just installed 3rd time.
If I modify any of the roles the home page where all the topics are listed is no more accessable, I got redirected to the Profile page with any user with any modified role...

@gwingwin if I do not modify the administrator's role (as after any role modification administrator role jump into the same issue) and set up a user like you mentioned, that user will get the administrator rights.

Please let me know how to make it work!

Thank you!

Having the same issue! I've just installed 3rd time. If I modify any of the roles the home page where all the topics are listed is no more accessable, I got redirected to the Profile page with any user with any modified role... @gwingwin if I do not modify the administrator's role (as after any role modification administrator role jump into the same issue) and set up a user like you mentioned, that user will get the administrator rights. Please let me know how to make it work! Thank you!
edited 2 days ago at 4:16 pm

I'm also getting this. One user contacted me and said they couldn't see any posts. It's not obvious to new users that they need to click the site title/logo to go to the homepage.

I'm also getting this. One user contacted me and said they couldn't see any posts. It's not obvious to new users that they need to click the site title/logo to go to the homepage.
84
7
5
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft